Vá lỗi The Active field needs to be updated

Submitted by superthin on 14/06/2019 - 11:03:24
Path Drupal 8.7.3

Hôm nay Thin tiến hành cập nhật Drupal lên phiên bản mới nhất, tức phiên bản Drupal 8.7.3. Trong quá trình cập nhật, gặp ngay lỗi có dòng như tiêu đề bài viết này. Điều điên đầu & cũng thú vị nhất của Drupal đó là nó có một cộng đồng hùng mạnh với những lập trình viên PHP đủ đẳng cấp từ gà mờ cho đến cao thủ võ lâm.

Chính vì cái cộng đồng Drupal náo loạn kia nên việc tra cứu lỗi để xử lý không khó. Chỉ cần vào drupal.org, dán nguyên câu vá lỗi về là đã gặp như sau:

Bài thảo luận về lỗi đó có đoạn:

Entity/field definitions
Mismatched entity and/or field definitions
The following changes were detected in the entity type and field definitions.
Profile

The Active field needs to be updated.

Đích xác cái lỗi cần vá. Thế là chạy vài lệnh đã vá xong. Cuối cùng chạy update.php là hoàn tất. Mọi sự đã êm đẹp./.